PDA

View Full Version : COM2 Port can not recognize



vinodpaliwal
12-17-2000, 01:59 PM
I have internal modem connected to my computer. I have been using it since past two years. My PC was infected with Virus so I formatted the hard drive and reinstall the Windows 98. Now during the installation, the windows is not recognizing the internal modem. When I manually select my modem, the windows is trying to search in COM1 port though it should look at COM2 port where modem is connected. When I looked at Systems Manager, COM ports, COM2 port doesn't appear in the ports list. I believe COM2 port has been desabled. I don't know how it happened, but I am not able to configure the modem. Please help me, how can I enable COM2 port?

------------------
Vinod Paliwal

Paleo Pete
12-17-2000, 04:47 PM
Whether the COM port needs to be enabled depends on the type of modem. For hardware modems, COM2 should be disabled in BIOS. It's 3F8, usually in Integrated Periferals. BIOS Survival Guide (http://www.manawatu.gen.nz/pages/bios_survival/bios_sg.htm) might help.

If it's a winmodem, HCF or HSF modem, COM2 should be enabled in BIOS, and the modem must be installed by a software installation program, not by the Add Hardware Wizard.

------------------
Soon as I come up with all the answers...they change the questions!!

Computer Information Links (http://www.geocities.com/paleopete/)

Reid
12-17-2000, 05:37 PM
I have had COM ports disappear when reloading Windows, so you may need to go to Add New Hardware in the Control Panel and make it search for COM ports again. It would probably be a good idea to remove the modem before redetecting the COM ports.

------------------
reido@my-deja.com

Paleo Pete
12-18-2000, 07:08 AM
Reid has a good idea there...

Also, I was wrong, COM2 is 2F8, not 3F8, that's COM1.

------------------
Soon as I come up with all the answers...they change the questions!!

Computer Information Links (http://www.geocities.com/paleopete/)