PDA

View Full Version : Do something about this Microsoft's Windows Ugly Feature...



healtheworld
06-08-2003, 12:10 PM
Hello friends

I hv been trying to find The solution of renewing the IP Address In XP/2k/98/me for several purposes like CABLE Modem connections, Small Home Networks. But if the IP address is 169.254.*.*

IT SHOWS THAT NIC(HARDWARE) IS WORKING ..(Am i correct..)

According to Site http://www.practicallynetworked.com/

Problem: Network Connection Has IP Address 169.254.x.x

Description: The network card is configured to obtain an IP address automatically, and itís connected to a network with a DHCP server: hardware router, another computer running Internet Connection Sharing, cable modem, DSL modem, etc. But it gets a 169.254.x.x IP address, which indicates that it canít communicate with the DHCP server:

Possible Solutions:

Connect the computer using a different Ethernet cable or hub/switch/router port.
Download and install the latest firmware for the hardware router.
Disable XPís Internet Connection Firewall on the local area network connection.
The card is configured to automatically sense network speed and duplex mode, but auto-sensing is failing. Configure the speed and duplex mode manually. For example, most switches and routers use 100 Mb speed and full duplex. To make the settings, right click the network connection and click Properties | Configure | Advanced.
Un-install the network card and move it to a different slot.
If you have a cable modem connection, turn off the computer, turn off the cable modem, and wait a few minutes. Turn on the cable modem, and then turn on the computer.

If I try to renew it Gives an Error [/u]
Error enewing a DHCP lease fails, with error message ďAn error occurred while renewing interface <name>: The system cannot find the file specified.Ē

Problem: Network connection configured to obtain an IP address automatically has IP address 0.0.0.0
Solution: Make sure that the DHCP Client service is running:
Right click My Computer, and click Manage.
Double click Services and Applications.
Double click Services.
Double click DHCP Client. If the Service status is Stopped, click Start.
Set the Startup type to Automatic.
Thanks to Lightcap, who suggested this fix in a news group message.


Even tried disabling APIPA

Method
=====
Disabling APIPA

In rare situations, you might want to disable APIPA, which you do by modifying client Registry. Run regedt32.exe and go to HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Services\Tcpip\ Parameters\Interfaces. Select the adapter for which you want to disable APIPA. Add the value IPAutoconfigurationEnabled of data type REG_DWORD and set it to 0 to disable it, as Screen 2 shows. This entry isn't present by default because the OS enables APIPA and assumes a value of 1. You need to add this value only if you want to disable APIPA. If you have multiple adapters and you want to disable APIPA for all of them, simply add the entry IPAutoconfigurationEnabled at the HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\ Tcpip\Parameters level and set it to 0


No Go....

Does it has anything to do with Winsock ... (My understanding it is not)
m basically talking about the cable/dsl modems. If during installtion we get an IP address 169.254.*.* , That means it is an internal IP address assiged by Windows . After performing all the steps that i hv mentioned in my original post, we hv still of cases in which we can't get an IP address from ISP DHCP server.

I really want to know , do you know any other tip thru which we can get rid of this windows APIPA address.

169.254.*.* proves that NIC is working fine and it is a problem with software (Am I correct)
I only want to know how to get rid of 169.254.*.*

I hv tried all the above options but success rates are very small
Lets Discuss it with U experts out here.....


Lets Discuss it with U experts out here.....

-------------------------
Make The World A better Place

classicsoftware
06-08-2003, 02:17 PM
You have a mess.

You can't run ICS and a router as they both attempt to act as DHCP servers.

So here is what you do:

1) Unhook everything.

2) Disable ICS

3) Disable the XP firewall.

4) Re-connect everything with the router as the DHCP server and all should
be well.


As for the IP address, the Cable Modem will give the IP address to the router. This is the "public" IP address the world will while you are line. The 169.x.x.x are the internal IP address's supplied by the router to the individual network cards.

Rick
06-08-2003, 02:27 PM
Isn't 192.254.0.0 the default loopback for the local network/nic ?

If you are running 2 dhcp servers
In the system you should have the IP, Subnet,Default gateway, Preferred DNS and Alternet DNS set

Running it in auto is not going to work 100% of the time

healtheworld
06-09-2003, 02:24 PM
Really appreciate every bit of help...

I m facing this problem in configuring a single cable / dsl modems
...

classicsoftware
06-09-2003, 10:15 PM
Did you follow the steps I outlined above???


Please advise. You are not providing enough information for us to help you.

Ghost_Hacker
06-10-2003, 06:48 AM
Have you tried running a sniffer to see the traffic going between this computer and the ISP DHCP server?

First thing you should do is verify that the two are talking to each other. (they proably are not)


You can not renew this "auto" assigned IP address which is why you get an error when you try to ( On the ICS host computer. Else all the DHCP clients will get IP addresses on that subnet since it is the address range used by ICS). However, you are free to use whatever IP you wish by manually configuring it. ( but I don't belive you can change the subnet used by ICS) Remember that the ICS clients will not be able to talk to the ISP's DHCP server, but instead will get their request for an IP address answered by the ICS DHCP server.(hence the 169.254.x.x range you see assigned) Also remember that it is not needed for the ICS clients to get an ISP assigned IP address. Only the ICS host needs one.

So is your problem that the HOST can't get an ISP assigned IP address, but instead is "answering itself" with an address in the 169.254 subnet?(note: that I'm talking about the interface connected to your broadband connection not the one connected to your lan. The LAN interface MUST use the subnet Microsoft assigned for ICS)


EDIT Here's a link to how to disable the ICS DHCP server if needed.(only on Windows 98, you can't turn off the ICS DHCP server on a Windows 2000 computer and proably not one on an XP box either.)

ICS.txt (http://support.microsoft.com/default.aspx?scid=%2Fsupport%2Fwindows%2Freadme%2F win98se%2Fw98seicstxt.asp)

I have never tried this, so good luck :)