PDA

View Full Version : cant get to SAFE MODE



Grumper
04-02-2004, 09:33 PM
I dual boot my C drive with an ASUS A7N8X motherboard---the problem is that I cant get to safe mode with the F8 key---When my choice of booting comes on screen and a line comes up on the bottom of the screen "press F8 to enter safe mode" it does not work---is this due to the fact that I have a dual boot situation in boot.ini ????

classicsoftware
04-02-2004, 09:51 PM
If you have a dual boot system, you should first get the boot menu. You would hit the f8 after you selected an OS and the booting process started.

Grumper
04-02-2004, 10:11 PM
That did not work---I selected the OS held the F8 key down and went right into the OS.

Thanks Anyway

shanmuga
04-03-2004, 01:15 AM
Which OS are you trying to start in safe mode? Are all the other function keys work? I think tweak UI has a setting which enables/disables function keys. In windows xp you can force, booting in safemode, by modifying the boot options in system configuration utility and in 9x and me system configuration utility can be used to 'enable startup menu', which will display the startup menu for fixed seconds on every boot.In Win2k the option is F8 only.

You can also try pressing the ctrl key, it works sometimes.

Quantax
04-03-2004, 01:17 AM
I happen to also have a dual boot setup(Win 98 and XP)and when I keep pressing the F8 it takes me to the XP startup menu. If, however, I wish to get the 98 menu, I need to enable the startup menu option in msconfig.

ErnieK
04-03-2004, 03:59 AM
Grumper
If you boot into 98 and go to System properties and select show boot menu this will pause at 98 (when selected) selection where you have 5 choices, you can choose safe mode from here. This will then ask you which OS you want for safe mode. This is the old Win98 boot screen and avoids the use of the F8 or F5 keys.

Grumper
04-03-2004, 07:32 AM
my dual boot OS choices are both Win XP Pro [long story] F8 and control + F8 dont work ?????

Paul Komski
04-03-2004, 09:11 AM
WinXP

Add a duplicate line to boot.ini to the one that boots WinXP and then modify everything after the = sign to "Microsoft Windows XP Safe Mode" /fastdetect /SAFEBOOT:MINIMAL
Choose this option to boot into Safe Mode for WinXP

Win98

Run msconfig and On the General tab, click the Advanced button - Check Enable Startup Menu - Click OK twice and restart your computer - Select the Win98 boot option and then the Safe Mode Option.

Alternative

Select the boot option and have one finger over the Enter Key and one finger over the F8 key. Hit Enter immediately followed by F8. Bang-bang like a machine gun; you have to be really quick with a dual boot menu.

Grumper
04-03-2004, 03:39 PM
Paul I did as you stated --modified boot.ini

I get an error message stating "windows could not be started because the folling file is missing or corrupt

"[windows root] system32\hal.dll
please install a copy of the above file"

Dose this sound proper--Ive doubled checked your line and I have it correct ?????

Paul

Paul Komski
04-03-2004, 04:16 PM
Doesn't sound right - are you sure that your are trying to boot to the correct partition number? If the wrong partition is being referenced then you would get that error. Can you boot normally to WinXP or is that why you are trying to get into Safe Mode?

If you can boot normally with lines such as:-

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

These two lines should be edited to the following threee lines:-

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Safe Mode" /fastdetect /SAFEBOOT:MINIMAL

There would of course also be another line for booting to Windows 98 with a reference to C:\Windows

Grumper
04-03-2004, 05:17 PM
This is what I have now [adding the line you gave me] as you can see both OS are XP Pro

Im not having a problem loading either partition--Im just wondering why getting into "safe mode" seems to be a problem.

NOTE I made the 3 lines with a space betqween them--there is not a space in "boot.ini"

boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

multi(0)disk(0)rdisk(0)partition(0)\WINDOWS="Microsoft Windows XP Safe Mode" /fastdetect /SAFEBOOT:MINIMAL

multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Games Microsoft Windows XP Professional" /fastdetect

Thanks

Paul Komski
04-03-2004, 05:28 PM
As suspected you are referencing the wrong partition.

You need to edit:-

multi(0)disk(0)rdisk(0)partition(0)\WINDOWS="Microsoft Windows XP Safe Mode" /fastdetect /SAFEBOOT:MINIMAL

to read

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Safe Mode" /fastdetect /SAFEBOOT:MINIMAL

Grumper
04-03-2004, 07:35 PM
Paul as always you are "the man"------ partition (0), sure that reference would work on partition (1) or (2)--All is well now I edited the other partition and getting into SAFE MODE on either partition works like a dream--Thanks you very much.

I would buy you lunch if you lived a little closer :)

Really your expertise is really helpful for 95% of us on this site and I for one really appreciate your skills.

Thanks Paul [Grumper]