PDA

View Full Version : Weird "show desktop.scf"



kyeev
04-13-2007, 01:57 AM
Heres a weird problem someone might have a quick fix for.
(Running WinXP sp2)

The "show desktop.scf' icon has disappeared... BUT...
Have tried all the typical fixes including two automated restore tools and also writing a new "show desktop" file in notepad and saving as a scf file.
But to no avail.
Its sits there as an recognised file and asks which program it should use to open with each time its double clicked.

Can't find any mention of this problem anywhere.

Am using windows+D to minimise at the moment. oh the hardship...

Paul Komski
04-13-2007, 02:11 AM
Sounds like .scf file extension has been associated with "something". Normally there is no file association under MyComputer >> Tools >> Folder Options. If yours shows an extension consider deleting it - at your own risk of course ;) until we know the specifics since all these associations have linked registry entries.

I think the relevant registry key is:
HKEY_CLASSES_ROOT\.scf
and the Default Value should be a string value with valuedata:
SHCmdFile

PS
As with .lnk .url and .pif extensions the .scf is a super-hidden file extension and so the .scf itself should never be visible

If the .scf extension is visible then the registry key:
HKEY_CLASSES_ROOT\SHCmdFile
should have a valuedata key called NeverShowExt containing an empty string
Deleting that key allows the superhidden scf to show and adding it back should re-hide the file extension
A restart is then needed

kyeev
04-13-2007, 10:06 AM
sorry, meant "unrecognised file"

Anyway, will try that fix and post back.