View Full Version : 2nd Hard drive not recognised (unable to format it etc)

08-03-2001, 12:41 PM
I am running Win98 and have a 6.5gb hard drive fitted.
I have been given another hard drive which is 1.7gb but when I fitted it Win98 will nor recognise it.
I have fitted the second drive as slave and it has been auto detected by Bios but will not show in windows.
I have tried to run FDISK and FORMAT the second drive but it will not work and I think that it has the NTFS file system on it, is that the reason I cant't run FDISK and FORMAT from the Win98 start up disk?.
How do I convert NTFS to FAT32 I have tried using Partition Magic but the second drive is not shown.

08-03-2001, 08:33 PM
Welcome to the PC Guide Discussion Forums Broadsword http://www.PCGuide.com/ubb/smile.gif

It seems as though you have the cable and jumpers set correctly? If the HD is indeed using NTFS Windows 98 won't recognize it. When you tried fdisk did you use a boot floppy? Can switch to the drive in pure DOS? You will have to delete/remove the partition table on that HD before you can enable FAT32. Unless you want the data on the HD I wouldn't bother with converting from NTFS to FAT32. Be careful when using fdisk...make sure you are where you want to be.

Post back if this is no help so the other folks can offer some better advice http://www.PCGuide.com/ubb/smile.gif

Flush 'N' Forget
FE Stokes WWTP (http://www2.apex.net/users/hwuswtp)

Paleo Pete
08-04-2001, 12:36 AM
The NTFS file system has to be removed using the NT setup program, I'm not sure if fdisk will do it, since it won't recognize it. The NT setup program used to install NT has an option to manage partitions without actually installing NT on the hard drive.

Cool! I finally get some use out of my NT book... http://www.PCGuide.com/ubb/biggrin.gif

YOU! Out of the gene pool!
Note: Please post your questions on the forums, not in my email.

Computer Information Links (http://www.geocities.com/paleopete/)

08-04-2001, 10:30 PM
When I installed a second hard drive, weird things happened. The second drive was recognized but my cdrom was not. Win 98se saw this and told me to run setup again. This fixed the problem.

Give a man a fish, and you feed him for a day. Teach him yo use the net, and he wont bother you for weeks.

08-06-2001, 12:33 PM
Broadsword has problem I had before. If it is ntfs, then surprisingly enough, a win98se startup disk will recognize it. Mine did. Just make sure when you go to fdisk, choose the option that switches your harddrives, then choose the option that removes a Non Dos Partition (not sure about this one). Anyways, it should recognize it and be able to remove the ntfs. It's just under a different option as opposed to if you were removing a fat or fat32.

08-08-2001, 10:18 AM
Thanks eveyone I have now sorted it. http://www.PCGuide.com/ubb/smile.gif
I used the win98se startup and then ran FDISK and as mentioned by leichaolan deleted the Non Dos Partition after which I was able to partiton the drive.
I then formatted the drive (this took quite a while and kept saying TRYING TO RECOVER ALLOCATION UNIT ....)but I think that this may have been due to some bad sectors on the disk (which I later found when I ran SCANDISK).

08-11-2001, 05:25 AM
because that hard drive was, "trying to recover allocation unit..." when you formatted, failure might not be far away. This past week I had the occasion to experience this same scenario on a HD and sure enough 2 days later that HD failed. It wouldn't hurt to back up data just in case that 1.7 of yours goes south. It's food for thought.

Paleo Pete
08-11-2001, 08:37 AM
I agree, watch the drive closely and run scandisk every couple of days for a couple of weeks, see if it comes up with more bad clusters. If it does, the drive is definitely on its way to the graveyard. If it doesn't, it might hold up for a while, but I wouldn't put too much faith in it.

Support the right to keep and arm bears.
Note: Please post your questions on the forums, not in my email.

Computer Information Links (http://www.geocities.com/paleopete/)

08-13-2001, 10:58 AM
Thanks for the advice, I will keep a close eye on it.