PDA

View Full Version : OK, Samba expert needed



hiredgoonz
03-30-2001, 11:25 PM
Here's the deal:

Running Mandrake 7.2 and trying to get samba to allow me to have file access back and forth between the Linux machine, a Win2000 and another WinME...

I used SWAT to create the smb.conf...and I can access the WinME machine from Linux, but I cannot even find the Linux machine from either windows puter...and when I try to open the 2000 box from Linux, I get an access denied message, no login box or anything...and there are shared drives...

Workgroup name is identical...even usernames and passwords are the same on all the boxes...not running a firewall while trying this...I have created users added them to the smb.conf...

The main thing I don't understand is why I can see the workgroup on the linux machine, with the windows computers listed, but windows is too dumb to find a linux box...

Anyway, I probably didn't provide enough info, but I've only been using linux for about a month...I'd welcome any ideas, thanks

sleddog
03-31-2001, 07:04 AM
1. Sounds like you haven't allowed access from the Win box(es). Below is some stuff from my smb.conf. Look carefully especially at the "hosts allow" line.

2. Open smb.conf in a text editor as root and just edit it and save.

3. On some Windows systems you need to change a registry setting to use plaintext passwords to connect. This applies to Win 2000. Look around here:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\l anmanworkstation\parameters
and/or:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\l anmanworkstation\parameters

You'll see a value called: enableplaintextpassword
Double-click it and change it from 0 to 1. Reboot to take effect.

--------------------
Here are applicable lines from my smb.conf file:
--------------------

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = LABRADOR

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
hosts allow = 192.168.2. 192.168.1. 127.

# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = user

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
# See, I'm not using encripted security or anything elaborate on a closed, home network.
# The semi-colon disables these lines:
; encrypt passwords = yes
; smb passwd file = /etc/smbpasswd


----------------
These are shares, defined towards the end of smb.conf:
----------------

# User home directories appear in Network Neighbourhood:

[homes]
comment = Home Directories
browseable = no
writable = yes


# A sample restricted share.
# This share isn't visible in Network Neighborhood, but *I* can connect to it and write:

[data]
available = yes
path = /home/data
public = no
guest only = no
writable = no
browseable = no
write list = sleddog
only user = no


------------------
sleddog
[sleddog.f2s.com] (http://www.sleddog.f2s.com)

sleddog
03-31-2001, 07:16 AM
Forgot one important thing:

After editing /etc/smb.conf you *must* restart the Samba server for the changes to take effect.

On my RedHat system the command is (in a console, as root):

/etc/rc.d/init.d/smb restart

(A space before 'restart').

Not sure if Mandrake is the same -- though it's based on RedHat. And if you're using x I think the control panel has some doodad for starting/stopping/restarting daemons.


------------------
sleddog
[sleddog.f2s.com] (http://www.sleddog.f2s.com)

sea69
03-31-2001, 03:01 PM
WoW

------------------
**puff**.. "Put that thing out boy.. the Sheriff's a comin'!!"

hiredgoonz
03-31-2001, 10:17 PM
Thanks for all the info...I had already tried some of the things you mention, but I can see some areas where my smb.conf needs to be tweaked...guess that will be my next project...