PDA

View Full Version : Lost drive letter for cdrom



lampron
09-06-2000, 09:36 PM
This will be confusing but bear with me - I had a post here before about adding a 3rd ide drive to my machine along with a cdrom. I tried it and it recognized the 3rd drive and my cdrom but neither works. Soooo I took out the 3rd drive and tried to restore it to original with two ide's and one cdrom. I have lost my cdrom drive letter - it does not show or read cd's but the bios says it is there. In windows I went to system and device manager and my hard disk controller (both) have exclamation marks beside them and so does the cdrom. I have tried removing them and reinstalling them but still no drive letter for cdrom and still exclamation marks. I have one ide master and one slave on one controller on motherboard and cdrom as slave on the other controller on motherboard. It worked before and cdrom was drive e: as was harddisk master c: and harddisk slave d:. I can still boot into windows 98se and access everything except cdrom although light on cdrom works and bios sees it. I tried to see if I could change drive letter to e: on cdrom in system device manager but there is no setting tab to do that. I saw the settings tab before I messed with this and now it is not there. Can anyone help???? I have tried disconnecting each and reconnecting but always comes up the same. (ps - when I put the 3rd drive in it took the letter e: - and did not move cdrom to the next letter and now there is no e: at all even after taking 3rd drive out) I have a headache now http://www.PCGuide.com/ubb/frown.gif(

dale
09-06-2000, 09:47 PM
You need to put your CDROM back to MASTER on your secondary controller.
dale

dale
09-06-2000, 09:49 PM
Also, when you tried the 3rd drive and CDROM combo and neither worked - what does that mean. Meaning Windows wouldn't show either as being available as a drive? Did you check your BIOS to makes sure the secondary controller is enabled (probably is since you had your CDROM on it at one point).

Did your device manager show anything when you had all 3 IDE drives and the CDROM?

As to the !s in the device manager when you have just 2 drives and a CDROM, double click on those devices and go see what the error message is.

regards,
dale

DANQU
09-07-2000, 08:13 PM
Hi Dale
Do you thing he is having the same problem I had when adding a harddrive with a CD-RW?
if so he should read or discussion on this matter at:

"IBM harddrive not seen in DOS but
seen in Windows 98 Second edition"

When seeing !s maybe a drive problems too?
Dan