Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 4 of 4

Thread: boot error - missing operating system

  1. #1
    Join Date
    Mar 2002
    Location
    kettering, northants, UK
    Posts
    2

    Thumbs down boot error - missing operating system

    Converted from FAT32 (XP upgrade from Win98). Then to NTFS on clean install of Win XP Pro failed. After intial blue screen boot during install, the subsequent rebboot gave missing operating system.

    Have tried Fixmbr & Fixboot. (after re formating the disk to FAT 32 from NTFS).

    On boot (from C :
    Missing operating system

    On booting from floppy after formating:
    Windows could not start because the following file is missing or corrupt:
    <Windows root>\system32\hal.dll
    Please reinstall a copy of the above file

    Having done the more obivious checks (boot order, acitive partition, boot.ini and fixing boot records etc - see above.), I think the orginal Maxblaster easy install MBR overlay done for win 95 (see orginal posting) is causing the problem (not compatible with XP - NTFS, but orginally OK with XP & FAT32?!).

    Any ideas how I can get around this and make the disk bootable again? Or any other pearls of wisedom?

    Cheers

  2. #2
    Join Date
    Nov 2000
    Location
    Milwaukee Wi
    Posts
    4,988

    Post

    If your running Maxblaster for the MBR / overlay
    I’m going to assume your Bios doesn’t support the drive you installed in the system.
    When you installed XP on fat32 you didn’t modify the overlay.

    If you reinstall the overlay and keep it Fat32 you should not have any hassles.
    Unless your XP install overwrites it. This may in fact be the reason of the BSOD during xp install

    The files you are showing as missing are the NT loader

  3. #3
    Join Date
    Mar 2002
    Location
    kettering, northants, UK
    Posts
    2

    Question

    Thanks Rick.

    Had tried the newer version of Maxblaster (used it orginally to copy image from old drive), it skips format (although it appears to indicate it has successfully formated my drive). No further progress. The orginal version crashes (divide error). So, back to square one!

    Oh dear...

  4. #4
    Join Date
    Nov 2000
    Location
    The Mountain State
    Posts
    23,354

    Post

    If there isn't much on the dirve that you want to keep you may have to start all over from scratch......and reinstall the original overlay and keep everything FAT32, or update the overlay and try again. You may need to use the wipe utility from Maxtor to totally wipe the drive before you begin.

    ------------------
    mjc
    Links list:Computer Links

    Celts are the men that heaven made mad, For all their battles are merry and their songs are all sad.
    AV, Anti-Trojan List;Browser and Email client List;Popup Killer List;Portable Apps
    “When men yield up the privilege of thinking, the last shadow of liberty quits the horizon.” - Thomas Paine
    Remember: Amateurs built the ark; professionals built the Titantic."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •