Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 8 of 8

Thread: LPT1 Error when trying to print.

  1. #1
    Join Date
    Feb 2001
    Location
    England
    Posts
    38

    LPT1 Error when trying to print.

    When I'm trying to print a document through WinME the system starts to print and then comes back with an error message stating that:

    "There was an error writing to LPT1 for the Printer (Epson Stylus C62 Series) The system cannot write to the specified device."

    I have removed the printer and re-installed it, installed a different printer and even re-installed a ghost image of my system. All to no avail.

    I have not installed or removed any software since the printer last worked and I have no viruses.

    The printer works fine on another PC so I can rule out printer/cabling problems.

    Anyone have anything I have overlooked.

  2. #2
    Join Date
    Jul 2001
    Location
    Wyncote, PA, USA
    Posts
    10,241
    Make sure the cable is IEEE1284. If you have a bi-directional port and and a uni-directional cable, it may not work. Also, the port may be bad.
    Do other printers work on this computer?

  3. #3
    Join Date
    Feb 2002
    Location
    Somerset, England
    Posts
    2,762
    One other thought. What is the parallel port setting in BIOS?
    EPP/ECP or whatever? It should be set to EPP or ECP for bi-directional communication.

    If the printer has ever worked correctly then scratch that!

    David
    be wary of strong drink - it may make you shoot at tax collectors, and miss!

  4. #4
    Join Date
    Mar 2002
    Location
    west Lothian, Scotland.
    Posts
    13,273
    The “Tuff-Test Lite” free Diagnostic Programme from http://www.tufftest.com/free.htm includes a printer test and uses DOS as the operating system.
    Once you have installed the software on your PC and used it to make a diagnostic floppy, you simply switch on the PC with the floppy in place and sit back and watch the tests take place.[or hit “Enter” to eliminate the pauses]

    If the printer test comes out as successful, then you know there’s nothing wrong with the hardware or the BIOS.
    The problem must lie with the O/S.

    EDIT
    I've just read the info page and it doesn't say it does a printer test, just serial and parallel ports.
    When I used it though, I'm sure the printer was activated and some characters were printed, probably to test the parallel port.
    Last edited by Sylvander; 06-12-2003 at 03:34 PM.

  5. #5
    Join Date
    Jun 2001
    Location
    Scottish Borders
    Posts
    3,519
    wundermutt
    Another thing to try is to delete the port in Device manager. Then reboot computer where the port will be found and re-installed. this should get rid of any errors in the port.
    Ernie

    The difference between perseverance and obstinancy is that one is made from strong will, and the other from strong won't
    Henry Ward Beecher
    Do you have reading problems? Don't let it deter you. This is what YOU can do if you try http://www.erniek.eclipse.co.uk

  6. #6

    Same problem here!

    My computer setup has not changed for years but now I can no longer print to lpt1. I have two printers attached to it through a switch box and neither will work. I believe the printers and cables are fine. Attached both directly to my laptop and printed normally. I have also attached the printers directly to ltp1 (eliminating the switch box) but that doesn't work. Tried removing the port and reinstalled - didn't work. Checked the bios and it is set for bi-directional - changed it to ECP no luck. Both Device Manager and the Tuff-Test Lite indicate the port is operating normally. However, Tuff-Test Lite could not see a printer.

    This problem occurred when I was on vacation during which there was a pretty good electrical strom. I lost both garage door openers. Do you think it also got my parallel port (not having any other problems with the machine)? And if so what is the fix. The computer is a pretty old Sony with the parallel port built on the motherboard and no available expansion slots.

    Any help would be appreciated.

    Thanks.

  7. #7
    Join Date
    Mar 2002
    Location
    west Lothian, Scotland.
    Posts
    13,273
    My Diagnostic Flowcharts might help here.
    If anyone wants a copy they should send me a PM requesting them [zipped or not] and giving an e-mail address to send them to.

    This one might apply.
    PARALLEL PORT
    1. Printer does not function correctly. True.
    2. Run Printer self test. [Have you done that?]
    3. Is the self test ok? If not your printer is faulty.
    4. If it is ok, then DISCONNECT THE PRINTER and run diagnostics on the parallel port.
    5. Is an error present? If there is then the I/O adaptor or system board is faulty.
    6. If not then check the printer cable. If the cable is not ok then replace it with a good one and re-test the printer.
    7. If the cable IS ok then the I/O adaptor or system board is faulty.
    [I cannot understand the logic of 7. If someone does could they explain why?]
    [I think I get it. The diagnostics are failing to detect a fault, but the fault does exist. Must exist since the printer and cable are both good. Hmmmm.]

    I re-ran “Tuff-Test Lite” again just to check and when the parallel port was tested a set of characters was printed out 5 times and the sheet of paper ejected.

    I know that with some other diagnostic software you can use “Loop-Back Plugs” on the serial and parallel ports to test them more thoroughly.
    Signals are sent out and the returns from the Loop-Back Plugs detected to confirm perfect operation.
    My PC was supplied with such software by “Eurosoft (UK) Ltd” though I never bought the plugs from them.
    You can buy them at Maplin in the UK but Eurosoft told me you had to use their version with their software.
    Last edited by Sylvander; 06-16-2003 at 07:00 PM.

  8. #8
    Thanks Sylvander. I'm pretty convinced that it is a bad parallel port. I have tried the printer and cable on another computer and they work fine. Since the port is built on the motherboard, it looks as if I will have to install a parallel port card. I don't have any available slots but I don't use the i-Link ports so I think I'll swap it out. This is an old 450 mHz PII that I plan on replacing sometime soon - just not yet. I will try to limp along a little bit longer.

    Thanks again.
    Rlchard

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •