Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 4 of 4

Thread: Number Lock is Stuck!

  1. #1
    Join Date
    Jul 2003
    Location
    Atlanta, GA
    Posts
    4

    Number Lock is Stuck!

    When I turn on my computer and go to enter my password (in 2000 Professional)on my laptop I have to press number lock first and then type in my password b/c the number lock is always on for some reason. I went into the BIOS and looked at the NUMLOCK setting and it was already turned off. I even turned it on to see if there was a difference. There wasn't. Anybody have an idea?

  2. #2
    Most laptops require the number keys to double up as function keys.
    It could well be that the keys are locked during bootup because otherwise they may invoke a function which interrupts the boot sequence.
    regardless of the CMOS settings, it could be possible for the manufacturer to hard code the lock into the BIOS.

  3. #3
    Join Date
    Jul 2002
    Location
    Minn
    Posts
    17,373
    It may also require a key combination to unlock the keys. Look for an FN key and look in your manual for info on how to use it to determine such functions. It may also involve a network setting if you are on a network.

    And Welcome to
    Budfred ..... Caveat Emptor....

    Helpful links SpywareBlaster... HijackThis... ATF Cleaner...

    Post a complaint about malware here!!
    So how did I get infected in the first place??

    MS MVP 2006 and ASAP member since 2004...

    If you PM me for help, expect an irritated response... Post in the forum...

  4. #4
    Join Date
    Apr 2002
    Location
    NC
    Posts
    2,385
    Ok try this first, turn off numlock key, shut down, restart. Sounds simple, but make sure if you want it off on boot up it's off at shutdown.


    That said.. I found this with google. It is worth a shot. I did not write these instructions. These are for changing the num lock to be ON, SO I would assume instead of putting "2" you might try "1" for always OFF? Screen shot or back up what you did so you can change it back if XP chokes.
    Anyway,
    Quote begins:
    The complete Instructions

    click: start menu
    all programs
    accessories
    windows explorer
    my computer
    localdiskC:
    windows
    regedit
    HKEY_USERS
    .DEFAULT
    Control Panel
    Keyboard
    InitialKeyboardIndicators
    change the value to 2
    hit ok
    close all windows programs
    reboot your computer
    ... and your done...
    End Quote:

    Also, may want to search MS knowledge base for
    Q314879 - "How to Set the NUM LOCK State at Logon in Windows XP

    This fellow has some more info..
    Begin Quote:
    Like Ann said in her original question, changing the value of InitialKeyboardIndicators under HKEY_USERS\.DEFAULT\Control Panel\Keyboard from 0 to 2 worked for me, but only initially at bootup -- once Windows XP loaded, it would off and stay off until I turn it on myself. So I tried the VB script mentioned in MSKB article Q314879, but that didn't work for me either. Finally I tried Jeff's suggestion of searching for additional registry entry instances of InitialKeyboardIndicators -- I found several instances, and changed the 2 or 3 instances that had a value of 0 to 2, and this finally worked for me. HTH

    End Quote:
    Its amazing how stupidly complicated it is to change a basic setting isn't it? Thanks MS.

    V
    V
    Last edited by Variable; 07-30-2003 at 02:45 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •