Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 6 of 6

Thread: Can't flash Intel D945 bios

  1. #1
    Join Date
    Nov 2000
    Location
    Milwaukee Wi
    Posts
    4,988

    Can't flash Intel D945 bios

    This is strange
    I have downloaded and used both the ISO and the easy bios flash for an Intel D945p mother board

    In both cases it will prepair the image for lan, logo, and so on
    Then it stops at flashing lan...

    Nothing happens from then on.
    Reset the system and it comes back up with no problem
    BUT still shows the old version

    The Bios jumper on this mother board are 1-2 for admin
    2-3 normal
    removed for recovery

    On the Admin setting it adds a few extra options to the bios setup ( admin screen) to allow you clear the passwords
    On normal there is no setting to allow bios to be flashed
    When removed it just keeps loooking for the BIO repair/backup file


    The reason for wanting the bios update
    The Mother board see's all 4 gig of ram
    But windows only shows 3.5 under properties

    Stranger still is the system Information shows
    Total Physical Memory 4,096
    Available Physical Memory 3.18


    The performance tab show 3668000 less the cache of 176628 for a total of
    3342896 available

  2. #2
    Join Date
    Nov 2000
    Location
    Milwaukee Wi
    Posts
    4,988
    Wouldn't you know it.
    I can't find the answer to the memory info on Intels site.
    So Where do I find it?
    Asus web site
    If you installed total 4GB memory, the system will detect less than 4GB of total memory because of address space allocation for other critical functions, such as:

    - System BIOS (including motherboard, add-on cards, etc..)
    - Motherboards resources
    - Memory mapped I/O
    - configuration for AGP/PCI-Ex/PCI
    - Other memory allocations for PCI devices

    Different onboard devices and different add-on cards (devices) will result of different total memory size.
    e.g. more PCI cards installed will require more memory resources, resulting of less memory free for other uses.
    That answers the memory question
    But why no bios flash/update
    the Intel web site and search don't show anything worth reading
    They did email me a link to the Intel? Integrator Toolkit Technical Support

    But Intel doesn't list the bios file for use with the tool kit.

  3. #3
    Join Date
    Oct 2001
    Location
    Derby, England
    Posts
    2,282
    I dont know if these mite help,

    http://support.intel.com/design/motherbd/nt/nt_mem.htm

    http://www.wimsbios.com/ Also look through the forum.

  4. #4
    Join Date
    Nov 2000
    Location
    Milwaukee Wi
    Posts
    4,988
    Thanks Jiggy for the links.
    I had already given the Intel site a look over

    As it turns out.
    I downloaded and used the bios update ISO, Windows version and then I installed a floppy drive and used the Good old DOS version of Iflash

    I have No idea why but the DOS version is the ONLY one that worked..
    I now have the latest bios installed a solved a few problems.

    The Memory address is something we have to live with.
    I think I know why it shows 3 amounts of ram in all the screens.
    The old scsi card is loading it's bios as well as the sata/scsi and then all the normal stuff.

    Thanks again
    If all else fails Use DOS

  5. #5
    Join Date
    Jan 2004
    Location
    Here
    Posts
    10,487
    The good ol' floppy comes through again.

    Yeah floppy drives usually sit around gathering dust most of the times, but there are times when it really pays to have one.
    8.1 Pro 64bit
    AMD FX 8350
    Asus Sabertooth 990FX R2.0
    24GB GSkill/Corsair 1866MHz
    2x XFX 6870 1GB
    SSD - OCZ V4 128GB/Kingston 120GB
    HDD - 3TB/2x 750GB/500GB/250GB
    Corsair TX850M
    Cooler Master HAF 932 Red
    CM Hyper 212 EVO w/2x SickleFlow 120mm Red
    12x BD-ROM
    Logitech X540 5.1 Surround
    2X Acer 23" LED - Eyefinity: 3840x1080
    Microsoft Sidewinder x4 KB

    "The significant problems we face cannot be solved at the same level of thinking we were at when we created them."
    - Albert Einstein

  6. #6
    I know this is a bit of an old post but I still see the issue coming up elsewhere and I have just found the solution myself so i thought I'd 'share the wealth'. My bios was version 3869 92006) and nothing I tried, ISO, exe older, newer revisions worked whatsoever. Every option the 'flashing lan' message would hang. I disabled the lan in bios and then tried the ISO and hey presto success! I did not need to progressively update by versions: I went straight to the last (2009) version which worked first go.

    Hope this helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •