Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 3 of 3

Thread: Problems with New Build - No display, no beeps

  1. #1

    Problems with New Build - No display, no beeps

    Hi

    Just finished building my first machine. Here are the specs:

    - Gigabyte GA-P31-DS3L - Motherboard
    - Intel Core 2 Duo E4600
    - XFX GeForce 8400 GS Graphics Card
    - Sony DRU-190S DVD/RW
    - 300W Power supply
    - 2GB PC2-5300 DDR2 Memory RAM DDR2-667 667MHz 2 x 1GB
    - SATA 500GB HDD

    So I turned it on, everything seems to be fine - all the fans are working, the lights are on the MOBO, DVD Drive and HDD are both powered up, Graphics card fan is going.

    I know the power supply and monitor are both fine as took them from my old machine.

    BUT - there is no display on the monitor, and there were no beeps when it started up. So, I stripped it down; disconnected all the drives, removed the video card, and one of the RAM sticks as well.

    When I turn on I get lights and fans again, but no beeps.

    My understanding is that this is either a fault with the CPU or the MOBO and I should one/both checked out, and return them if necessary. Am I right in thinking this or is there something very simple that I'm missing here?

    Thanks in advance.

  2. #2
    Have you checked all your power connections including the CPU 4 pin atx connector on the MOBO?

    The veterans here should confirm this.. your PSU seems to be less than adequate.
    "...wave upon wave of demented avengers march cheerfully out of obscurity into the dream..." Roger Waters

  3. #3
    Join Date
    Oct 2001
    Location
    N of the S of Ireland
    Posts
    20,504
    You should try a bare bones boot out of the case and also see if you can get beeps when no RAM is installed.
    Take nice care of yourselves - Paul - ♪ -
    Help to start using BiNG. Some stuff about Boot CDs & Data Recovery Basics & Back-up using Knoppix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •