Custom Search
Join the PC homebuilding revolution! Read the all-new, FREE 200-page online guide: How to Build Your Own PC!
NOTE: Using robot software to mass-download the site degrades the server and is prohibited. See here for more.
Find The PC Guide helpful? Please consider a donation to The PC Guide Tip Jar. Visa/MC/Paypal accepted.
Results 1 to 4 of 4

Thread: Getting USB1 speed from USB2 on front port

  1. #1

    Getting USB1 speed from USB2 on front port

    I've recently replaced to a used motherboard.
    My problem could just be that I have a partially mal-functioning motherboard, but I wouldn't think the problem I am having would be common.. so I ask here...

    I have a front panel USB connections connected to the USB ports on motherboard. Motherboard has 2 USB ports with two rows of pins so that I can connect up to 4 USB connection in my front panel.

    When I connect a USB device (an external HDD) to the back panel (usb ports attached to the motherboard directly), I get USB 2.0 speed.
    When I connect the same USB device to the front panel, I get a message saying something like "device is USB2 device and will perform better on USB2 port" and that I get USB 1 speed.

    I assume the front panels are at USB1 speed because when I try to copy files, the front panel ports takes 3-4 times longer for exact same files.

    I've never seen such behavior and message with previous motherobards that I've used. The manual also says this motherobard supports upto 8 USB2 devices (4 on back panel, 4 by connection port). And I think I have the wires properly connected where one row of the pins has one less pin so that my wire labeled as "shield" is not connected.

    It's not a huge problem, but I'd like to fix it if possible.

    Any ideas on what might be causing such problem?

    The motherboard that's giving this problem is: MSI PM8M-V (http://www.msi.com/index.php?func=pr...=1&prod_no=205)
    And I've used all their latest drivers except that it didn't have a separate USB driver so using what Windows XP detected. I am not at this computer at the moment to tell exactly what it shows in the device manager, but generally one of the items in the USB controller says "USB2", but I only saw Enhanced USB controller or something similar to that and that makes me very suspicous and wonder how those in back panel is working in USB2 mode...

  2. #2
    Join Date
    Sep 2008
    Posts
    263
    I ran into this and finally found out it was the cable too long or not properly shielded (or loose pin) to front panel. I tried a short cable from another machine and it worked. Go figure. Also if there is a connector for the 5 volts wake up on MB, try it on the other side, this somehow give more power to usb ports.
    Good luck.

  3. #3
    Hard to believe this problem is due to the cable because it's all same and it was working fine with previous motherboard.
    Maybe the loose pin... though I am pretty sure every pins are tight.
    I am not sure if there's "connector for the 5 volts wake up on MB".

    But... I can't think of anything, so you just may be right and I got lucky with last motherboard and this one maybe because I had to stretch it or position the wire differently from last motherboard, could possibly make differences...
    Though I have two of these front USB panel used in two separate computers and other one works fine too.. hmm...

  4. #4
    Join Date
    Dec 2007
    Location
    CT
    Posts
    1,852
    if it's all plugged in correctly outside the computer and you either moved the computer, or you did work inside it, always check the connections when things don't work right. Does this happen in some flavor of linux as well?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •